КОНФЕРЕНЦИЯ СТАРТКОПИ
Принтеры, копировальные аппараты, МФУ, факсы и другая офисная техника:
вопросы ремонта, обслуживания, заправки, выбора


Рейтинг@Mail.ru Переход в графическую версию
Логин:
Пароль:

Samsung ML2015: красная лампочка и тишина

0. Suhov 04.09.21 23:31

При включении ни каких признаков жизни, только красная лампочка. Движком не крутит, компом не определяется. Если зажать единственную кнопку- входит в режим прошивки, компом определяется, пытается прошиваться, по крайней мере реагирует на отправленную на него прошивку. Сам на перезагрузку не уходит, после передергивания кабеля питания- снова красная лампочка. Пробовал разные прошивки- результат одинаков. Прицепился дебагом- параметры, как из статьи по восстановлению 4200/4300- в терминал гонит мусор. Пробовал три разных переходника на PL2003, пробовал разные драйвера для них- в терминале только мусор. Пробовал разную скорость- иногда проскакивают некие символы, но бессистемные, т.е. гонит мусор. Нашел в хламе форматтер от ксерокса 3124. Подцепился- аппарат завелся, движком начал крутить, компом определился. Отправил на него прошивку от 2015. Плата физически не такая, по этому перепаял юпитер на родной форматтер- результат все тот же- красная лампочка, и в терминале мусор. Перепаял чип оперативки- без изменений. Все питания в норме и чистые, на всякий случай заменил 1117-е, ожидаемо- без результата. Есть у кого гарантировано рабочая прошивка на ML2015? Потому что в той, что я скачал- я не уверен. Пробовал к дампу проца цеплять заголовок от выкачанной прошивки- результата нет. Ну и приветствуются любые свежие мысли- может я вообще не в ту сторону смотрю?

1. _MAVR_ 04.09.21 23:40

на 2015 оригинал в свободном доступе... не раз скачивал...

http://printservis.com.ua/index.php/originalnye-proshivki

качал тут, проблем нет...

https://vce-o-printere.ru/download/o-proshivke-printera/120-skachat-original-nuyu-proshivku-samsung.html
Отредактировано 23:46 04.09.21 _MAVR_

2. Дмитрий.С 05.09.21 06:25

<code><cite>(0)</cite></code>1:1 форматер и в путь

3. kgbeast 05.09.21 07:37

(0)Так может флеха умерла?

4. Scuzzy 05.09.21 09:55

Так проц же менялся.
Имхо - цепляться за джитаг и смотреть чего творится.

5. СОВА 05.09.21 11:37

<cite><b>Suhov</b> (0): Пробовал разную скорость- иногда проскакивают некие символы, но бессистемные,</cite>
Опыт работы с дебагом у меня мизерный, в советчики особо не гожусь, но настройки сом порта имеют не только скорость, а и еще такие параметры как 7 или 8 битный режим обмена. Или еще есть бит контроля четности. И если не изменяет память, когда еще давно-давно работал со знакогенераторами матричных принтеров, нечто подобное и наблюдал. Изменение этих параметры могло давать мусор с редкими вкраплениями чего то похожего. 7 битный режим обмена это конечно абсурд, разве что недоглядеть. Но выход из строя или замыкание на дорожке данных ОЗУ может вызвать нечто подобное. Причем я бы посмотрел в первую очередь старший бит данных.
Отредактировано 11:40 05.09.21 СОВА

6. _MAVR_ 05.09.21 14:03

а не проще новый форматтер за 500 рублей поставить???

7. Scuzzy 05.09.21 14:09

(6) Нет, Василий никогда не ищет легких путей :))

8. СОВА 05.09.21 14:33

(6) (7) В принципе не исключается и битая прошивка. И основной посыл в (0) все таки рабочая прошивка. А все остальные записи, я так понял, это надежда, а вдруг не учел какой то мелочи.

9. СОВА 05.09.21 14:53

ЗЫ
<cite><b>СОВА</b> (5): на дорожке данных ОЗУ</cite> Не обязательно ОЗУ. И не обязательно шина данных, может и адреса. :)) Но где то в старших битах. Начало то программы похоже как то отрабатывает.

10. Suhov 05.09.21 21:23

(3) в проце она, он заменен
(4) а что я там увижу? опыта работы у меня с джитагом почти нет- вычитать/записать, не более. Jlink пойдет, или нужно что-то более взрослое?
(6) проще, но хочется понять- что с этим? Если вопрос не решится- буду менять всю плату, деваться некуда
(5) я с дебагом на самсунгах давно общался, проще флеху в прогер и все вопросы решены, по этому настройки брал не из памяти, а отсюда http://startcopy.ru/repair/sams4300_sc.htm

11. СОВА 06.09.21 00:11

Попробуй зайти
Мой компьютер-свойства-диспетчер устройств-Последовательный порт-свойства-параметры СОМ порта. Выбрать "управление потоком Xon / XoFF". Вроде так надо было. По умолчанию порт вроде не управляется и возможно переполнение потока.
Можно еще войти в
-дополнительно. И убрать там галочку в использовать буферы FIFO

В десятой винде не знаю.
Отредактировано 00:16 06.09.21 СОВА

12. serry 06.09.21 02:06

<cite><b>Suhov</b> (10): а что я там увижу? опыта работы у меня с джитагом почти нет- вычитать/записать, не более. Jlink пойдет, или нужно что-то более взрослое?</cite> Жилинк точно без проблем пойдёт. И команды не надо - набери в поисковике "принтержитаг", он уже бесплатный, эта прога сама всё сделает. МЛ2015 (точнее МЛ2010) в списке есть.
Только жилинк у себя я слегка доработал- провода с разъёмом сделал короткие+ выключатель кнопкой с фиксацией по питанию+ в стабилизаторе 3.3В на осн. плате поправил резисторы делителя, чтобы поднять питание на 0,1-0,2 В , чтобы гарантированно работало на питании от жилинка, т.е. без доп. питания.
Отредактировано 02:12 06.09.21 serry

13. serry 06.09.21 02:14

Пару раз этот принтержитаг здОрово выручал меня. Я тогда его ещё за денежку покупал, небольшую, т.к. поддерживаемое железо (т.е. клон-жилинк) уже было у меня.
Отредактировано 02:17 06.09.21 serry

14. Suhov 06.09.21 08:39

(12) есть у меня эта штука, так же покупал, в свое время. Оттуда и брал дамп, к которому в винхексе добавлял заголовок

15. kgbeast 06.09.21 10:15

(10)Ну так остаётся генерация. Можно попробовать махнуть U3 на самсунге с U10 на фазере

16. Suhov 06.09.21 18:28

(15) не помогло

17. kgbeast 06.09.21 18:59

(16)А сам кварц?

18. Suhov 06.09.21 19:14

(17)а нет, помогло.... После замены клокера прошился, ушел на перезагрузку, булькнул комп, дальше нет картриджа, кинул соплю на высоковольтной плате- работает, спасибо. Завтра прицеплюсь дебагом, посмотрю- что он туда говорит, или всётаки у меня три переходника дохлых)))

19. Suhov 07.09.21 18:09

а в терминале все тот же мусор. Буду разбираться- что не работает, из трех переходников один гарантировано рабочий

20. СОВА 07.09.21 18:18

<cite><b>Suhov</b> (19): а в терминале все тот же мусор.</cite>
(11) делал?

21. Suhov 07.09.21 18:46

(20) пробовал с разными настройками. Пару месяцев назад сменил ноут(старая система переехала на свежий ноут), может еще в этом дело. Аппарат забрали, так что буду потом разбираться, главное- что бы в голове отложилось, что терминал не работает, иначе через год снова буду удивляться- да какого х... оно не работает? )))


Принтеры, копировальные аппараты, МФУ, факсы и другая офисная техника:
вопросы ремонта, обслуживания, заправки, выбора

Переход в графическую версию
  Рейтинг@Mail.ru